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A. NỘI DUNG 
Chủ đề 6: Giải quyết vấn đề với sự trợ giúp của máy tính: Thực hành tạo và khai thác CSDL (bài 17, 18, 19 ,20, 21, 22, 23, 24)
		- Lợi ích của việc quản trị cơ sở dữ liệu trên máy tính.
	- Hệ quản trị cơ sở dữ liệu MySQL và phần mềm HeidiSQL.
	- Xác định các bảng dữ liệu, cấu trúc của bảng và các trường khóa. 
	- Tạo mới một cơ sở dữ liệu thực hiện thông qua giao diện của phần mềm quản trị CSDL HeidiSQL.
- Tạo các bảng và chỉ định được các khóa cho mỗi bảng, thiết lập được mối quan hệ giữa các bảng qua việc chỉ định khoá ngoài.
- Cập nhật và truy xuất dữ liệu các bảng, bảng dữ liệu có tham chiếu.
- Sao lưu, phục hồi dữ liệu.
Chủ đề 7: Phần mềm chỉnh sửa ảnh và làm video (bài 25, 26, 27, 28)
- Khái niệm ảnh số, phần mềm Gimp, các thao tác chỉnh sửa ảnh cơ bản: phong to, thu nhỏ, xoay, cắt ảnh.
- Các công cụ tinh chỉnh màu sắc, các công cụ vẽ.
- Tạo ảnh động.
B. CÂU HỎI TRẮC NGHIỆM
Câu 1: Hệ quản trị cơ sở dữ liệu (DBMS) là gì?
A. Phần mềm soạn thảo văn bản
B. Phần mềm quản lí dữ liệu
C. Phần mềm vẽ hình
D. Phần mềm trình chiếu
Câu 2: Phần mềm nào sau đây là hệ QTCSDL?
A. Word
B. Excel
C. MySQL
D. PowerPoint
Câu 3: Hệ QTCSDL giúp đảm bảo điều gì?
A. Tính toàn vẹn dữ liệu
B. Tăng tốc độ mạng
C. Giảm dung lượng RAM
D. Tăng kích thước màn hình
Câu 4: Ưu điểm nổi bật nhất của quản lí dữ liệu bằng máy tính là gì?
A. Trang trí đẹp
B. Xử lí nhanh và chính xác
C. Tiêu tốn nhiều giấy
D. Khó sử dụng
Câu 5: Phần mềm nào hỗ trợ làm việc với MySQL?
A. Paint
B. Notepad
C. HeidiSQL
D. Access
Câu 6: Hệ QTCSDL thường được ứng dụng chủ yếu trong lĩnh vực nào?
A. Nghe nhạc
B. Quản lí thông tin (khách hàng, nhân sự, kho...)
C. Chơi game
D. Vẽ tranh
Câu 7: MySQL là:
A. Phần mềm đồ họa
B. Hệ QTCSDL
C. Trình duyệt web
D. Hệ điều hành
Câu 8: Trong cơ sở dữ liệu, bảng (table) dùng để làm gì?
A. Lưu trữ chương trình
B. Lưu trữ dữ liệu theo dạng hàng và cột
C. Chạy phần mềm
D. Vẽ biểu đồ
Câu 9: Một hàng (record) trong bảng biểu diễn điều gì?
A. Một cột dữ liệu
B. Một đối tượng cụ thể (một bản ghi)
C. Một công thức
D. Một file
Câu 10: Một cột (field) trong bảng thể hiện điều gì?
A. Một bản ghi
B. Một thuộc tính của đối tượng
C. Một bảng
D. Một hệ CSDL
Câu 11: Trường khóa chính (Primary Key) là gì?
A. Trường chứa nhiều dữ liệu giống nhau
B. Trường dùng để phân biệt các bản ghi
C. Trường có thể bỏ trống
D. Trường không quan trọng
Câu 12: Giá trị của khóa chính phải như thế nào?
A. Có thể trùng
B. Có thể rỗng
C. Không trùng và không rỗng
D. Không cần xác định
Câu 13: Trong một bảng, có thể có bao nhiêu khóa chính?
A. Nhiều khóa chính
B. Chỉ một khóa chính
C. Không có khóa
D. Tùy ý
Câu 14: Kiểu dữ liệu của một trường dùng để làm gì?
A. Trang trí bảng
B. Xác định dạng dữ liệu lưu trữ
C. Tăng tốc độ mạng
D. Xóa dữ liệu
Câu 15: Cấu trúc bảng gồm những thành phần nào?
A. Chỉ có dữ liệu
B. Trường (cột) và bản ghi (hàng)
C. Chỉ có khóa
D. Chỉ có phần mềm
Câu 16: Khi tạo cơ sở dữ liệu mới, bước đầu tiên là gì?
A. Nhập dữ liệu
B. Đặt tên và tạo CSDL
C. Xóa bảng
D. In dữ liệu
Câu 17: Khi tạo bảng, cần xác định điều gì trước tiên?
A. Màu sắc
B. Các trường (field) của bảng
C. Hình nền
D. Âm thanh
Câu 18: Khi tạo bảng, cần chọn yếu tố nào cho mỗi trường?
A. Màu chữ
B. Kiểu dữ liệu
C. Hình ảnh
D. Âm thanh
Câu 19: Dữ liệu được nhập vào bảng theo dạng nào?
A. Hình ảnh
B. Âm thanh
C. Hàng và cột
D. Video
Câu 20: Khóa ngoài (Foreign Key) là gì?
A. Trường dùng để nhập dữ liệu
B. Trường liên kết với khóa chính của bảng khác
C. Trường không quan trọng
D. Trường chứa hình ảnh
Câu 21: Khóa ngoài dùng để làm gì?
A. Trang trí bảng
B. Tạo mối liên hệ giữa các bảng
C. Xóa dữ liệu
D. Tăng dung lượng
Câu 22: Trong một bảng, có thể có bao nhiêu khóa ngoài?
A. Chỉ một
B. Không có
C. Có thể có nhiều khóa ngoài
D. Không xác định
Câu 23: Khóa ngoài có thể trùng giá trị không?
A. Không bao giờ
B. Có thể trùng
C. Phải khác nhau
D. Không xác định
Câu 24: Cập nhật dữ liệu trong CSDL là gì?
A. Xóa toàn bộ dữ liệu
B. Thêm, sửa hoặc xóa dữ liệu trong bảng
C. Tắt máy
D. In dữ liệu
Câu 25: Truy xuất dữ liệu là gì?
A. Xóa dữ liệu
B. Lấy dữ liệu theo yêu cầu từ CSDL
C. Tạo bảng mới
D. Đóng phần mềm
D. Drop
Câu 26: Lệnh nào dùng để truy vấn dữ liệu?
A. Insert
B. Update
C. Delete
D. Select
Câu 27: Khi truy vấn dữ liệu, điều kiện lọc thường dùng mệnh đề nào?
A. Insert
B. Update
C. Where
D. Drop
Câu 28: Điều kiện nối bảng được viết trong mệnh đề nào?
A. WHERE
B. ON
C. GROUP BY
D. ORDER BY
Câu 29: ORDER BY dùng để làm gì?
A. Nhóm dữ liệu
B. Xóa dữ liệu
C. Sắp xếp kết quả
D. Thêm dữ liệu
Câu 30: Để truy vấn hai bảng qua liên kết khoá, câu truy vấn SQL nào sau đây là đúng?
 A. [image: ]
	B. [image: ] 
	C. [image: ] 
D. [image: ] 
Câu 31: Chính sách an toàn dữ liệu phải bao gồm?
A. Những quy định về ý thức đối với những người vận hành hệ thống
B. Những quy định về trách nhiệm đối với những người vận hành hệ thống
C. Bao gồm cả quy định về ý thức và trách nhiệm của người vận hành
D. Không cần quy định cụ thể
Câu 32: Để phục hồi CSDL, ta chọn lệnh nào?
A. Tập tin / Run SQL file…		 
B. Tập tin / Load SQL file… 
C. Tập tin / Lưu				 	
D. Tập tin / Nhập file cài đặt…
Câu 33: Để thay đổi giao diện hiển thị một cửa sổ của phần mềm GIMP, em thực hiện như thế nào?
A. Chọn File → Open.
B. Chọn Edit → Preferences.
C. Chọn Windows → Single-window Mode.
D. Nhấn Ctrl + N.
Câu 34: Để phóng to hoặc thu nhỏ ảnh trong GIMP, em cần thực hiện thao tác nào?
A. Nhấn phím Shift + P.
B. Chọn nút lệnh Zoom và nháy chuột vào vị trí muốn phóng to hay thu nhỏ.
C. Sử dụng tổ hợp phím Ctrl + Z.
D. Kéo thả ảnh ra ngoài khung làm việc.
Câu 35: Để cắt ảnh trong GIMP, em cần sử dụng công cụ nào?
A. Crop.
B. Cut.
C. Eraser.
D. Move.
Câu 36: Độ phân giải của ảnh thường được đo bằng gì?
A. Số lượng màu sắc.
B. Số điểm ảnh trên một inch (dpi hoặc ppi).
C. Kích thước file ảnh.
D. Kích thước vật lý của ảnh.
Câu 37: Lựa chọn nào dưới đây giúp ảnh động lặp lại liên tục trong GIMP sau khi xuất ra file GIF?
A. Infinite loop	
B. Repeat animation
C. Loop forever	
D. Play again
Câu 38: Nêu chức năng của công cụ Clone trong Gimp?
A. Vẽ bằng cách sao chép một vùng chọn. 
B. Xoá điểm ảnh trên lớp đang chọn hoặc một vùng chọn. 
C. Vẽ bằng cách sao chép chính xác một vùng chọn. 
D. Tô màu chuyển sắc vùng chọn.
Câu 39: Để lưu tệp tin ảnh đang làm việc trong GIMP ở định dạng xcf, em cần chọn lệnh nào?
A. File → Export.
B. File → Save.
C. File → Open.
D. File → Close.
[bookmark: _Hlk227788075]Câu 40: Để xuất một bức ảnh sang định dạng jpg trong GIMP, em cần chọn lệnh nào?
A. File → Save As.
B. File → Export.
C. File → Print.
D. File → Close.
Câu 41: Công cụ Color Balance trong GIMP được sử dụng để:
A. Thay đổi độ bão hòa màu cho toàn bộ ảnh.
B. Cân bằng màu cho các lớp ảnh hoặc vùng chọn bằng cách điều chỉnh từng kênh màu.
C. Điều chỉnh tông màu của từng lớp màu trong ảnh.
D. Tăng độ sáng cho các điểm ảnh tối trong ảnh.
Câu 42: Công cụ Hue-Saturation cho phép điều chỉnh yếu tố nào?
A. Độ sáng và độ tương phản của ảnh.
B. Tông màu, độ sáng và độ bão hòa cho từng mảng màu trên ảnh.
C. Mức độ chi tiết và độ sắc nét của ảnh.
D. Kích thước và hình dạng của vùng chọn.
Câu 43: Khi chọn công cụ Rectangle Select Tool trong GIMP, phim tắt nào được sử dụng?
A. Shift + R
B. Ctrl + T
C. R
D. Alt + R
Câu 44: Để xử lý một bức ảnh thiếu sáng, em nên sử dụng phần mềm nào sau đây?
A. GIMP.
B. Inkscape.
C. PowerPoint.
D. Microsoft Word.
Câu 45: Điểm ảnh thường có hình dạng gì?
A. hình tam giác đều	
B. hình lập phương 1mm2	
C. hình bát giác	
D. hình vuông nhỏ
Câu 46: Công cụ Brightness-Contrast trong GIMP chủ yếu được sử dụng để làm gì?
A. Điều chỉnh độ sáng và độ tương phản cho toàn bộ ảnh hoặc một phần của ảnh.
B. Điều chỉnh cân bằng màu cho các kênh màu riêng biệt.
C. Chọn các vùng trên ảnh để áp dụng hiệu ứng.
D. Tăng độ sắc nét cho ảnh.
Câu 47: Chức năng nào sau đây của GIMP cho phép ta xem trước thay đổi trước khi áp dụng chỉnh sửa?
A. Reset
B. Preview
C. Auto-adjust
D. Adjustments
Câu 48: Để xuất tệp ảnh động GIF từ GIMP, ta cần chọn định dạng file nào trong hộp thoại Export?
A. PNG
B. GIF
C. JPEG
D. BMP
Câu 49: Để điều chỉnh màu sắc trên một phần ảnh mà không ảnh hưởng đến toàn bộ ảnh, ta cần sử dụng công cụ gì?
A. Levels
B. Free Select Tool
C. Rectangle Select Tool
D. B và C đều đúng
Câu 50: Công cụ Free Select Tool thường được dùng để:
A. Tạo một vùng chọn có hình dạng tùy ý.
B. Điều chỉnh độ sáng cho từng phần ảnh.
C. Tăng độ tương phản cho toàn bộ ảnh.
D. Cân bằng màu cho toàn bộ ảnh.
Câu 51: Vì sao quản lí CSDL trên máy tính chính xác hơn thủ công?
A. Do có tính toàn vẹn dữ liệu
B. Do ghi tay đẹp hơn
C. Do không cần nhập liệu
D. Do không cần kiểm tra
Câu 52: Vì sao CSDL giúp tìm kiếm nhanh hơn?
A. Vì dữ liệu ít
B. Vì có công cụ tìm kiếm và lọc
C. Vì không cần lưu trữ
D. Vì chỉ có một người dùng
Câu 53: Yếu tố quan trọng nhất giúp MySQL phổ biến là gì?
A. Giao diện đẹp
B. Miễn phí, dễ dùng và ổn định
C. Dung lượng lớn
D. Chạy offline
Câu 54: Muốn làm việc với CSDL cần gì?
A. Chỉ cần máy tính
B. Chỉ cần dữ liệu
C. Hệ QTCSDL và phần mềm giao tiếp
D. Không cần gì
Câu 55: Vì sao cần chọn khóa chính cho bảng?
A. Để bảng đẹp hơn
B. Để phân biệt các bản ghi và tránh trùng lặp
C. Để giảm dung lượng
D. Để in dễ hơn
Câu 56: Vì sao không nên chọn trường “Họ tên” làm khóa chính?
A. Vì quá ngắn
B. Vì có thể trùng nhau giữa nhiều người
C. Vì khó nhập
D. Vì không cần thiết
Câu 57: Khi thiết kế bảng, vì sao cần xác định kiểu dữ liệu cho từng trường?
A. Để trang trí
B. Để nhập và xử lí dữ liệu chính xác
C. Để tăng kích thước file
D. Để giảm số hàng
Câu 58: Khi nào nên dùng kiểu số thay vì kiểu văn bản?
A. Khi lưu tên
B. Khi cần tính toán
C. Khi lưu địa chỉ
D. Khi lưu mô tả
Câu 59: Vì sao cần chọn kiểu dữ liệu phù hợp cho mỗi trường?
A. Để trang trí
B. Để tránh lỗi khi nhập và xử lí dữ liệu
C. Để tăng số bảng
D. Để giảm số cột
Câu 60: Nếu chọn sai kiểu dữ liệu cho trường, điều gì có thể xảy ra?
A. Máy tính tắt
B. Không lưu được bảng
C. Nhập sai dữ liệu hoặc không xử lí được
D. Không hiển thị
Câu 61: Khi tạo nhiều bảng trong CSDL, vì sao cần thiết kế hợp lí?
A. Để dễ nhìn
B. Để liên kết và quản lí dữ liệu hiệu quả
C. Để tăng dung lượng
D. Để giảm dữ liệu
Câu 62: Vì sao cần dùng khóa ngoài thay vì gộp tất cả dữ liệu vào một bảng?
A. Để bảng dài hơn
B. Để tránh dư thừa và dễ quản lí dữ liệu
C. Để tăng số cột
D. Để dễ in
Câu 63: Vì sao khóa ngoài phải cùng kiểu dữ liệu với khóa chính?
A. Để đẹp
B. Để đảm bảo liên kết chính xác giữa các bảng
C. Để tăng dung lượng
D. Để dễ nhập
Câu 64: Vì sao cần dùng điều kiện khi truy vấn dữ liệu?
A. Để đẹp hơn
B. Để lấy đúng dữ liệu cần thiết
C. Để tăng dung lượng
D. Để giảm bảng
Câu 65: Vì sao phải kiểm tra dữ liệu trước khi cập nhật?
A. Để tăng tốc độ
B. Để tránh sai sót và mất dữ liệu
C. Để tăng số bảng
D. Để giảm số cột
Câu 66: Khi truy vấn dữ liệu từ nhiều bảng, cần sử dụng gì?
A. Delete
B. Insert
C. Liên kết bảng (INNER JOIN)
D. Drop
Câu 67: Vì sao nên sao lưu dữ liệu trước khi cập nhật lớn?
A. Để tăng tốc độ
B. Để có thể khôi phục khi có lỗi
C. Để giảm dung lượng
D. Để đẹp hơn
Câu 68: Vì sao cần kiểm tra khóa ngoài trước khi thêm dữ liệu?
A. Để đẹp
B. Để đảm bảo dữ liệu hợp lệ và liên kết đúng
C. Để tăng dung lượng
D. Để giảm bảng
Câu 69: Khi cập nhật bảng có tham chiếu, điều gì giúp tránh lỗi?
A. Tăng dung lượng
B. Tuân thủ ràng buộc toàn vẹn
C. Đổi màu
D. Xóa bảng
Câu 70: Chọn câu SAI về khoá ngoài?
A. Để khai báo khoá ngoài, chọn thẻ Check constraints.
B. Khoá ngoài có tác dụng liên kết dữ liệu giữa các bảng.
C. Để khai báo khoá ngoài, chọn thẻ Foreign keys.
D. Các trường là khoá ngoài của bảng là các trường tham chiếu đến một trường khoá chính (k) của một bảng khác vì vậy cần được khai báo giá trị mặc định phù hợp với giá trị tương ứng của k.
Câu 71: Xây dựng kế hoạch sao lưu dữ liệu dự phòng như thế nào?
A. Thiết lập một kế hoạch định kỳ để sao lưu dữ liệu
B. Đảm bảo tính thường xuyên, đúng đắn và đầy đủ
C. Kết hợp cả việc lập lịch định kỳ và đảm bảo tính đầy đủ, chính xác
D. Chỉ sao lưu khi cần
Câu 72: Thực hiện cấu hình tính năng sao lưu dữ liệu dự phòng để?
A. Đảm bảo tính nhanh chóng khi phục hồi dữ liệu
B. Đảm bảo quá trình sao lưu thường xuyên
C. Đáp ứng yêu cầu tổ chức và đảm bảo an toàn dữ liệu
D. Giảm dung lượng dữ liệu
Câu 73: Cần thực hiện các kiểm tra định kỳ để?
A. Đảm bảo tính thường xuyên của sao lưu
B. Đáp ứng yêu cầu tổ chức
C. Đảm bảo quy trình sao lưu hoạt động hiệu quả và an toàn
D. Giảm dung lượng
Câu 74: Cần cấu hình và xây dựng kế hoạch phục hồi dữ liệu trong trường hợp?
A. Khi có sự cố bất ngờ
B. Khi dữ liệu bị lỗi
C. Khi có rủi ro xảy ra
D. Trong mọi tình huống có thể gây mất dữ liệu
Câu 75: Để tổ chức đảm bảo an toàn CSDL phục vụ công tác quản lí của một tổ chức, cần?
A. Xây dựng chính sách truy cập dữ liệu với những kế hoạch về tất cả các phương án sự cố có thể xảy ra và giải pháp hạn chế, khắc phục
B. Xây dựng chính sách bảo vệ người dùng với những kế hoạch về tất cả các phương án sự cố có thể xảy ra và giải pháp hạn chế, khắc phục
C. Xây dựng chính sách an toàn dữ liệu với những kế hoạch về tất cả các phương án sự cố có thể xảy ra và giải pháp hạn chế, khắc phục
D. Chỉ cần sao lưu dữ liệu
Câu 76: Khi điều chỉnh màu sắc với công cụ Color Balance, nếu muốn điều chỉnh các điểm ảnh sáng nhất trong ảnh, ta sẽ chọn dải màu nào?
A. Shadows
B. Midtones
C. Highlights
D. Hue
Câu 77: Khi lớp ảnh không có kênh Alpha, điều gì sẽ xảy ra khi sử dụng công cụ Erase?
A. Điểm ảnh bị xoá sẽ trở thành màu nền
B. Điểm ảnh bị xoá sẽ biến mất hoàn toàn
C. Điểm ảnh bị xoá sẽ trở thành màu nỗi
D. Không thể xoá điểm ảnh
Câu 78: Công cụ Healing khác công cụ Clone ở điểm nào?
A. Healing chỉ sao chép vùng ảnh mà không kết hợp màu sắc
B. Healing kết hợp màu sắc của vùng được sao chép để phù hợp với vùng chỉnh sửa
C. Clone xoá các điểm ảnh không mong muốn còn Healing chỉ thêm chi tiết
D. Healing chỉ dùng để vẽ các chi tiết mới
Câu 79: Giá trị độ phân giải càng cao thì ảnh được in ra càng:
A. Rõ nét.
B. Mờ.
C. Tươi sáng.
D. Rực rỡ.
Câu 80: Với cùng một ảnh, tăng giá trị độ phân giải thì ảnh được in ra có kích thước như thế nào?
A. Nhỏ hơn.
B. To hơn.
C. Không đổi.
D. Độ phân giải không thay đổi 
Câu 81: Để chỉnh độ sáng và độ tương phản cho ảnh trong GIMP, ta chọn:
A. Colors / Brightness-Contrast		
B. Colors / Color Balance 
C. Colors / Hue-Saturation		 	
D. Colors / Shadows-Highlights
Câu 82: Để xoay một bức ảnh trong GIMP, em cần thực hiện thao tác nào?
A. Chọn Rotate và nhập góc xoay.
B. Nhấn Ctrl + X.
C. Kéo thả ảnh ra ngoài khung làm việc.
D. Chọn Image → Flip.
Câu 83: Công cụ vẽ trong GIMP có mấy nhóm chính?
A. 2 nhóm
B. 3 nhóm
C. 4 nhóm
D. 5 nhóm
Câu 84: Nếu ảnh có hình chiếc đĩa hình tròn, em dùng công cụ nào để chọn chiếc đĩa đó? Phím tắt chọn công cụ đó là gì?
A. Dùng công cụ Rectangle Select Tool, phím tắt là R 
B. Dùng công cụ Ellipse Select Tool, phím tắt là E 
C. Dùng công cụ Free Tool, phím tắt là F 
D. Dùng công cụ Ellipse Select Tool, phím tắt là R
Câu 85: Với ảnh có kích thước 400 x 600 pixel, nếu in với độ phân giải 200 dpi, kích thước của hình ảnh sẽ là bao nhiêu inch?
A. Kích thước chiều ngang = 4 inch, kích thước chiều dọc = 6 inch
B. Kích thước chiều ngang = 400pixel /200dpi = 2 inch, kích thước chiều dọc = 600pixel /200dpi = 3 inch
C. Kích thước chiều ngang = 600pixel /200dpi = 3 inch, kích thước chiều dọc = 400pixel /200dpi = 2 inch
D. Kích thước chiều ngang = 400pixel /600dpi = 0.66 inch, kích thước chiều dọc = 600pixel /400dpi = 1.5 inch
Câu 86: Quan sát cửa sổ Layer bên dưới và cho biết lớp nào đang hiển thị, lớp nào không hiển thị?
[image: ]
A. Lớp Hoa thược dược đang hiển thị, lớp Đồng quê và lớp Quả tảo không hiển thị. 
B. Lớp Đồng quê và lớp Hoa thược dược đang hiển thị, lớp Quả táo không hiển thị. 
C. Lớp Đồng quê và lớp Quả táo đang hiển thị, lớp Hoa thược dược không hiển thị. 
D. Lớp Hoa thược dược và lớp Quả táo đang hiển thị, lớp Đồng quê không hiển thị.
Câu 87: Với công cụ Color Balance, nếu muốn điều chỉnh các điểm ảnh trung bình trong ảnh, ta sẽ chọn dải màu nào?
A. Shadows
B. Midtones
C. Highlights
D. Hue
Câu 88: Với công cụ tinh chỉnh màu sắc Hue-Saturation, ta có thể điều chỉnh thông số nào?
A. Contrast
B. Lightness
C. Highlights
D. Brightness
Câu 89: Khi nói về các công cụ vẽ, điều nào sao đây sai?
A. Bucket Fill dùng để tô màu vào vùng chọn
B. Gradient dùng để tạo bóng mờ cho ảnh
C. Clone dùng để vẽ bằng cách sao chép chính xác một vùng chọn
D. Healing dùng để vẽ bằng cách sao chép một vùng chọn
Câu 90: Nếu một lớp ảnh lớn hơn khung hình động, ta sẽ nhận được thông báo gì khi xuất file GIF từ GIMP?
A. "Layer size is too large."
B. "The image is too large to export as GIF."
C. "The image you are trying to export as a GIF contains layers that extend beyond the actual borders of the image."
D. "Image export failed due to layer size."
Câu 91. Khi CSDL được tổ chức tốt thì điều gì xảy ra?
A. Khó tìm kiếm hơn
B. Truy xuất dữ liệu nhanh và chính xác hơn
C. Dữ liệu bị mất
D. Máy chậm đi
Câu 92: Để xóa một liên kết khóa ngoài đã tạo trong HeidiSQL, ta thực hiện:
A. Xóa cột đó ở tab Cấu trúc.
B. Vào tab Khóa ngoại, chọn liên kết cần xóa, nhấn nút dấu trừ (Remove) và nhấn Save.
C. Chuột phải vào bảng chọn Drop.
D. Xóa toàn bộ CSDL.
Câu 93: Trong thẻ “Dữ liệu” (Data) của HeidiSQL, làm thế nào để sửa trực tiếp giá trị của một ô dữ liệu?
A. Phải viết câu lệnh UPDATE
B. Phải xóa dòng đó đi nhập lại
C. Nháy đúp chuột (hoặc nhấn F2) vào ô cần sửa, nhập giá trị mới và nhấn Enter
D. Không thể sửa trực tiếp được
Câu 94: Cặp trường nào không được trùng lặp giá trị trong bảng bannhac(idBannhac, tenBannhac, idNhacsi)?
A. idBannhac và idNhacsi
B. tenBannhac và idNhacsi
C. idBannhac và tenBannhac
D. idNhacsi và tenNhacsi
Câu 95: Khi chỉnh sửa dữ liệu trong bảng, để sửa nội dung của một ô dữ liệu, ta thực hiện thao tác nào?
A. Nhấn đúp chuột vào ô cần sửa
B. Chọn ô rồi nhấn phím Deletex
C. Chọn ô rồi nhấn phím Ctrl + Enter
D. Chọn ô rồi nhấn phím F
Câu 96: Một bảng “Học sinh” có trường “Mã lớp” liên kết với bảng “Lớp”. Trường “Mã lớp” trong bảng “Học sinh” là gì?
A. Khóa chính
B. Trường phụ
C. Khóa ngoài
D. Không cần thiết
Câu 97: Quan sát hình bên dưới và cho biết vì sao trường idNhacsi xuất hiện chữ (NULL).
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A. Vì trường idNhacsi là khoá không trùng lặp nên không cần nhập dữ liệu cho trường này.
B. Vì trường idNhacsi là khoá chính nên không cần nhập dữ liệu cho trường này.
C. Vì trường idNhacsi là khoá ngoài nên không cần nhập dữ liệu cho trường này.
D. Vì trường idNhacsi có kiểu INT, AUTO_INCREMENT (tự động điền giá trị) nên không cần nhập dữ liệu cho trường này.
Câu 98: Khi nháy đúp chuột vào biểu tượng phần mềm HeidiSQL, một cửa sổ như hình bên dưới xuất hiện. Để vào cửa sổ làm việc của HeidiSQL, đối với các máy tính ở phòng thực hành Tin học của trường THPT Nguyễn Việt Hồng, ta cần nhập mật khẩu nào vào ô Mật khẩu?
[image: ]
	A. 02923846008	B. nguyenviethong		C. 12345		D. nvh12345
Câu 99: Câu lệnh SQL nào dưới đây dùng để truy vấn thông tin tên bản nhạc và tên nhạc sĩ từ hai bảng bannhac và nhacsi trong CSDL mymusic?
	A. SELECT * FROM bannhac WHERE idNhacsi = nhacsi.idNhacsi
	B. SELECT tenBannhac, tenNhacsi FROM bannhac WHERE bannhac.idNhacsi = nhacsi.idNhacsi
	C. SELECT tenBannhac, idNhacsi FROM bannhac WHERE idNhacsi = (SELECT idNhacsi FROM nhacsi)
	D. SELECT bannhac.tenBannhac, nhacsi.tenNhacsi FROM bannhac INNER JOIN nhacsi ON bannhac.idNhacsi = nhacsi.idNhacsi 
Câu 100: Muốn truy xuất dữ liệu các ca sĩ có "idcasi" là 1 ta dùng câu truy vấn nào sau đây?
	A. SELECT * FROM casi WHERE tencasi LIKE '%Hoa%';
	B. SELECT * FROM casi;
	C. SELECT * FROM casi WHERE tencasi LIKE 'N%';
	D. SELECT * FROM casi WHERE idcasi = 1;
Câu 101: Trong CSDL mymusic, để thực hiện việc tìm kiếm bản nhạc của nhạc sĩ Văn Cao trong bảng bannhac, ta cần làm gì?
	A. Không thể tìm kiếm.
	B. Truy xuất theo thứ tự giảm dần của tên bản nhạc, rồi tìm “Văn Cao”.
	C. Lọc theo trường idBannhac .
	D. Lọc dữ liệu theo trường idNhacsi tương ứng với nhạc sĩ Văn Cao.
Câu 102: Bảng HOCSINH(MaHS, TenHS, Diem). Muốn lấy danh sách học sinh có điểm lớn hơn 8, câu lệnh nào đúng?
A. SELECT TenHS FROM HOCSINH WHERE Diem < 8;
B. SELECT * FROM HOCSINH WHERE Diem = 8;
C. SELECT * FROM HOCSINH WHERE Diem > 8;
D. SELECT TenHS FROM HOCSINH;
Câu 103: Bảng HOCSINH(MaHS, TenHS, Diem). Muốn lấy danh sách học sinh có điểm khác 5, câu lệnh nào đúng?
A. SELECT * FROM HOCSINH WHERE Diem = 5;
B. SELECT * FROM HOCSINH WHERE Diem <> 6;
C. SELECT * FROM HOCSINH WHERE Diem <> 5;
D. SELECT * FROM HOCSINH WHERE Diem > 5;
Câu 104: Bảng HOCSINH(MaHS, TenHS). Muốn sắp xếp danh sách học sinh theo tên tăng dần, câu lệnh nào đúng?
A. SELECT * FROM HOCSINH ORDER TenHS;
B. SELECT * FROM HOCSINH SORT BY TenHS;
C. SELECT * FROM HOCSINH ORDER BY TenHS ASC;
D. SELECT * FROM HOCSINH GROUP BY TenHS;
Câu 105: Bảng DONHANG(MaDH, MaKH) và KHACHHANG(MaKH, TenKH). Muốn lấy danh sách đơn hàng kèm tên khách hàng, câu lệnh nào đúng?
A. SELECT MaDH, TenKH FROM DONHANG INNER JOIN KHACHHANG;
B. SELECT MaDH, TenKH FROM KHACHHANG INNER JOIN DONHANG ON TenKH = MaKH;
C. SELECT MaDH, TenKH FROM DONHANG INNER JOIN KHACHHANG ON DONHANG.MaKH = KHACHHANG.MaKH;
D. SELECT MaDH FROM DONHANG WHERE MaKH = TenKH;
Câu 106. Kết quả của câu lệnh
SELECT * FROM HOCSINH WHERE DIEM > 8 AND LOP = '11A1' là gì?
A. Tất cả học sinh
B. Học sinh lớp 11A1 có điểm lớn hơn 8
C. Học sinh điểm dưới 8
D. Học sinh tất cả lớp 11
Câu 107. Câu lệnh
SELECT * FROM HOCSINH ORDER BY DIEM DESC có kết quả như thế nào?
A. Sắp xếp tăng dần
B. Sắp xếp học sinh theo điểm từ cao xuống thấp
C. Lọc học sinh giỏi
D. Xóa dữ liệu
Câu 108. Nếu viết câu lệnh
SELECT * FROM HOCSINH WHERE DIEM = 10 OR DIEM = 9
thì kết quả là gì?
A. Không có dữ liệu
B. Học sinh có điểm 9 hoặc 10
C. Học sinh tất cả điểm
D. Học sinh dưới 5
Câu 109. Câu lệnh nào sai cú pháp?
A. SELECT * FROM HOCSINH
B. SELECT TEN FROM HOCSINH WHERE DIEM > 8
C. SELECT FROM HOCSINH * WHERE DIEM > 8
D. SELECT * FROM HOCSINH ORDER BY DIEM
Câu 110: Bảng BANTHUAM(Mid, Sid) và BANNHAC(Mid, TenBN). Muốn lấy tên bản nhạc đã được thu âm, câu lệnh nào đúng?
A. SELECT TenBN FROM BANTHUAM INNER JOIN BANNHAC ON BANTHUAM.Sid = BANNHAC.Mid;
B. SELECT TenBN FROM BANNHAC WHERE Mid IN (SELECT Sid FROM BANTHUAM);
C. SELECT TenBN FROM BANTHUAM INNER JOIN BANNHAC ON BANTHUAM.Mid = BANNHAC.Mid;
D. SELECT TenBN FROM BANNHAC GROUP BY TenBN;
Câu 111: Bảng HOCSINH(MaHS, TenHS, MaLop) và LOP(MaLop, TenLop). Muốn lấy tên học sinh và tên lớp, câu lệnh nào đúng?
A. SELECT TenHS, TenLop FROM HOCSINH INNER JOIN LOP ON HOCSINH.MaHS = LOP.MaLop;
B. SELECT TenHS, TenLop FROM HOCSINH INNER JOIN LOP ON HOCSINH.MaLop = LOP.MaLop GROUP BY TenHS;
C. SELECT TenHS, TenLop FROM HOCSINH INNER JOIN LOP ON HOCSINH.MaLop = LOP.MaLop;
D. SELECT TenHS FROM HOCSINH WHERE MaLop = TenLop;
Câu 112: Nếu một ảnh có kích thước 300 × 400 pixel và in ra kích thước 3 × 4 inch thì độ phân giải  là bao nhiêu?
A. 100 dpi
B. 300 dpi
C. 400 dpi
D. 900 dpi
Câu 113: Trong GIMP, khi muốn thao tác cùng lúc trên nhiều lớp, ta cần thực hiện bước nào?
A. Chọn lệnh Merge Down
B. Nhấp chuột vào ô vuông thứ hai (biểu tượng sợi dây xích) bên cạnh các lớp muốn thao tác
C. Chọn lệnh Duplicate Layer
D. Nhấp chuột vào biểu tượng mắt để hiển thị tất cả các lớp
Câu 114: Để xem trước ảnh động ngay trong GIMP, ta thực hiện thao tác nào?
A. File → Export As
B. Filters → Animation → Playback
C. Image → Play Animation
D. Filters → Animation → Loop Forever
Câu 115: Lệnh nào cho phép ta thêm hiệu ứng vào ảnh động trong GIMP?
A. Filters → Blur
B. Filters → Animation
C. Layer → Effects
D. Image → Effects
Câu 116: Trong GIMP, thao tác nào sau đây là đúng để xoá một chi tiết nhỏ mà không làm ảnh hưởng đến phần khác của ảnh?
A. Sử dụng công cụ Healing với cọ lớn
B. Sử dụng công cụ Erase trên toàn bộ vùng ảnh
C. Sử dụng công cụ Clone và chọn vùng nguồn tương ứng
D. Tẩy toàn bộ lớp ảnh
Câu 117: Khi xuất tệp ảnh động trong GIMP, tùy chọn nào dưới đây đảm bảo rằng ảnh sẽ lặp lại liên tục sau khi hiển thị từ đầu đến cuối?
A. Nháy vào ô As Animation.
B. Nháy vào ô Loop forever.
C. Nhập giá trị thời gian cho các khung hình chưa được đặt thời gian.
D. Chọn đúng loại tệp đầu ra là GIF.
Câu 118: Kích thước của hình ảnh in với độ phân giải 200 dpi sẽ như thế nào so với hình ảnh in với độ phân giải 100 dpi?
A. Bằng
B. Lớn hơn gấp 2 lần
C. Nhỏ hơn gấp 2 lần
D. Lớn hơn gấp 3 lần
Câu 119: Với công cụ Ellipse Select Tool, nhấn giữ phím Shift để thực hiện:
A. Tạo vùng chọn thì vùng chọn được trừ bớt đi vùng chọn mới.
B. Sao chép vùng chọn mới
C. Tạo vùng chọn mới thì vùng chọn mở rộng thêm vùng chọn mới.
D. Di chuyển vùng chọn mới
Câu 120: Để chỉnh độ bão hòa màu cho bức ảnh ta thực hiện:
A. Colors  Brightness-Contrast
B. Colors  Color Balance
C. Colors  Hue-Saturation
D. Image  Scale Image
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